Installing CF 7 on W2K3 SP 2

I was having some problems trying to install ColdFusion 7 on Windows Server 2003 SP 2 last week. The installer would complete with errors and ColdFusion wouldn't start. Looking at the installation log I was seeing a few ANT script errors plus the following:

Web Server Connector Configuration Error
Status: ERROR
Additional Notes: ERROR - JNDI port 2902 for server coldfusion is not active

I found a blog post and a TechNote that seemed close to what I was experiencing, but the solutions seemed like a pain. Then I remembered DEP. I was able to run the ColdFusion installer after changing the DEP settings as follows:

  1. Click Start, click Run, type sysdm.cpl, and then click OK.
  2. On the Advanced tab, under Performance, click Settings.
  3. On the Data Execution Prevention tab, click "Turn on DEP for essential Windows programs and services only" to select the OptIn policy.
  4. Click OK two times.

Just to be on the safe side I would recommend changing this setting back to the default OptOut policy after completing the installation. You can do this by using the steps above, only select "Turn on DEP for all programs and services except those I select" for step 3.

Comments
Gary F's Gravatar The DEP solution only works in some cases. We had several servers and all required a scripted installation for it to work. The only plus side is once you've written the script the installation is many times faster than using the GUI installer.
# Posted By Gary F | 1/8/08 5:56 AM
BlogCFC was created by Raymond Camden. This blog is running version 5.8.001.