Installing 64 Bit CF 8.0.1 on Mac OS X 10.5.5

After attending a MegaLab at MAX I decided to re-install my local development version of CF so that I could install LiveCycle ES. I uninstalled CF 8 and then attempted a re-install, only to find the 64 bit CF 8.0.1 installer doesn't play well with the latest installation of Java on OS 10.5.5. After some unproductive googling someone on the Adobe forums pointed me to this post on Paul Marcotte's blog. In the comments of that post Rich Leach posted the following instructions to get the installer to work:

  1. In a terminal window, go to /System/Library/Frameworks/JavaVM.framework/Versions/CurrentJDK/Commands (cd /System/Library/Frameworks/JavaVM.framework/Versions/CurrentJDK/Commands)
  2. Remove the symlinks (sudo rm -rf *)
  3. Copy the files from /System/Library/Frameworks/JavaVM.framework/Versions/CurrentJDK/Home/bin to /System/Library/Frameworks/JavaVM.framework/Versions/CurrentJDK/Commands (sudo cp ../Home/bin/* .)
  4. Run the CF installer
  5. Remove the files from /System/Library/Frameworks/JavaVM.framework/Versions/CurrentJDK (sudo rm -rf *)
  6. Recreate the symlinks deleted in step 2 (sudo ln -s ../Home/bin/* .)

I don't usually re-post content from other blogs, but this one has been bothering me for a couple of days so I thought I'd help spread the answer. Maybe Adobe should put a TechNote out on this? And yes, I've already submitted a bug report.

Problems Seeing CF Installer Under Parallels

I just ran into an issue running the ColdFusion 8 installer on XP Pro in Parallels 3.0. When I first tried to run the installer I couldn't see the contents of the installer window. Turns out I had to stop the VM and change the video settings. I disabled DirectX support and custom screen resolutions was then able to see the installer with no problems. I had the same issue with CF 7 so it seems to be an issue with ColdFusion installer software and certain Parallels video settings.

BlogCFC was created by Raymond Camden. This blog is running version 5.8.001.